undefined symbol: json_vsprintf

covarrubiasgg

Well-known member
covarrubiasgg - Well-known member  
I had to format and restore a server today after the hard-drives died, but I encounter a new issue with Vicibox 9.0.3

After I made an zypper update and ignore the error for Pyton Repo, asterisk were crashing...

This was shown in the logs

Code:
    asterisk: symbol lookup error: asterisk: undefined symbol: json_vsprintf
The only way to fix it was by doing:

Code:
zypper install libjansson4-2.13.1-lp152.29.1.x86_64
This install libjansson4 with a vendor change and it did fix the error.
 

Kumba

Well-known member
Kumba - Well-known member  
The fix was added under the patch notes thread. Doing the above might break in the future, so please refer to the patch thread for the other method.
 
Hi,

I am using vicibox 9 with:
VERSION: 2.14-810a
BUILD: 210421-2227

And I am also facing the same issue. Asterisk is being crashed within a minute as soon as we start it.

Asterisk CLI shows the same error:

Code:
asterisk: symbol lookup error: asterisk: undefined symbol: json_vsprintf
I also tried installing "zypper install libjansson4-2.13.1-lp152.29.1.x86_64" as mentioned.
Here is the output:
Code:
vici9:~ # zypper install libjansson4-2.13.1-lp152.29.1.x86_64
Retrieving repository 'openSUSE-Leap-15.1-Devel-Languages-Python' metadata ...........................................................................................................[error]
Repository 'openSUSE-Leap-15.1-Devel-Languages-Python' is invalid.
[openSUSE-Leap-15.1-Devel-Languages-Python|http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_Leap_15.1/] Valid metadata not found at specified URL
History:
 - [|] Error trying to read from 'http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_Leap_15.1/'
 - Download (curl) error for 'http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_Leap_15.1/content':
Error code: Connection failed
Error message:


Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Skipping repository 'openSUSE-Leap-15.1-Devel-Languages-Python' because of the above error.
Problem retrieving files from 'openSUSE-Leap-15.1-Oss'.
Download (curl) error for 'http://download.opensuse.org/distribution/leap/15.1/repo/oss/repodata/repomd.xml':
Error code: Connection failed
Error message:

Please see the above error message for a hint.
Warning: Skipping repository 'openSUSE-Leap-15.1-Oss' because of the above error.
Problem retrieving files from 'openSUSE-Leap-15.1-PERL'.
Download (curl) error for 'http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_15.1/repodata/repomd.xml':
Error code: Connection failed
Error message:

Please see the above error message for a hint.
Warning: Skipping repository 'openSUSE-Leap-15.1-PERL' because of the above error.
Problem retrieving files from 'openSUSE-Leap-15.1-PHP-Applications'.
Download (curl) error for 'http://download.opensuse.org/repositories/server:/php:/applications/openSUSE_Leap_15.1/repodata/repomd.xml':
Error code: Connection failed
Error message:

Please see the above error message for a hint.
Warning: Skipping repository 'openSUSE-Leap-15.1-PHP-Applications' because of the above error.
Problem retrieving files from 'openSUSE-Leap-15.1-Update'.
Download (curl) error for 'http://download.opensuse.org/update/leap/15.1/oss/repodata/repomd.xml':
Error code: Connection failed
Error message:

Please see the above error message for a hint.
Warning: Skipping repository 'openSUSE-Leap-15.1-Update' because of the above error.
Problem retrieving files from 'openSUSE-Leap-15.1-ViciDial'.
Download (curl) error for 'http://download.opensuse.org/repositories/home:/vicidial/openSUSE_Leap_15.1/repodata/repomd.xml':
Error code: Connection failed
Error message:

Please see the above error message for a hint.
Warning: Skipping repository 'openSUSE-Leap-15.1-ViciDial' because of the above error.
Problem retrieving files from 'openSUSE-Leap-15.1-ViciDial-Ast13'.
Download (curl) error for 'http://download.opensuse.org/repositories/home:/vicidial:/asterisk-13/openSUSE_Leap_15.1/repodata/repomd.xml':
Error code: Connection failed
Error message:

Please see the above error message for a hint.
Warning: Skipping repository 'openSUSE-Leap-15.1-ViciDial-Ast13' because of the above error.
Some of the repositories have not been refreshed because of an error.
Loading repository data...
Reading installed packages...
Package 'libjansson4-2.13.1-lp152.29.1.x86_64' not found.
Resolving package dependencies...

Nothing to do.
Please suggest and help.

Thanks in advance.
 
close button
Top